
MICROSOFT PROJECT FIELDS
This document contains a description of all the task fields, resource fields, and 
resource assignment fields. This is the same information as you see in Microsoft 
Project Help when you get help about fields. 

Following each task and resource field name is a field number. This number can be 
used in place of the field name in MPX files to transfer project information to or from 
other applications. For more information about the MPX file format, see the online file
MPXFILE.WRI. The field number is also used in DDE. For more information about DDE, 
see the online file DDEINFO.WRI. 

If a field is marked as "Entered," you enter the information into the field. If it is 
marked as "Calculated," Microsoft Project uses information in other fields to calculate 
the value for this field, and you can't change this value.

Some fields are marked as both Calculated and Entered. In these fields, the 
information is calculated unless you enter your own information. If you delete the 
information you entered, Microsoft Project displays the calculated information.

Some fields can contain only a Yes or No. These fields appear as check boxes on the 
Resource Form, Task Form, and in edit form dialog boxes. For example, the Critical 
field contains a Yes if a task is critical or a No if a task is not critical.

TASK FIELDS

Task fields are all those you can use on the task views, such as the Gantt Chart, Task 
Sheet, and PERT Chart. These fields show the total information for each task. The 
fields are listed in alphabetic order. For information about the fields at the bottom of 
the Task Form, Task Details Form, and Task Name Form that show the information for 
each resource assigned to a task, see "Resource Assignment Fields" later in this 
document.

ACTUAL COST
Field #32
Calculated or Entered

Total cost actually incurred for the task; also called Actual Cost of Work Performed 
(ACWP). The actual cost is zero if you have not yet begun tracking the project. The 
actual cost for a task is the sum of the actual costs of all the assigned resources plus 
the fixed costs for the task to date. You can enter the actual cost for each of the 
assigned resources in the resource assignment Actual Cost fields at the bottom of the
Task Form or Resource Form. If a task has no resources assigned to it, you can enter 
the actual cost for the task.

If tasks are on schedule, you can use the Set Actual command on the Options menu 
to copy the scheduled fields for the tasks into the actual fields for the tasks.

For more information about using this field, see the "Costs" and "Tracking Progress" 
topics, and for more information about the relationship between planned, scheduled, 
and actual fields, see the "Fields" topic, all in the Microsoft Project User's Reference.



ACTUAL DURATION
Field #42
Calculated or Entered

Duration of the task that has actually been completed; for example, if a task's 
scheduled duration is three days and one day has passed, the actual duration is one 
day.

If you type a value in the Remaining Duration field or Percent Complete field, actual 
duration is calculated using the following formulas:

Actual Duration = Duration - Remaining Duration 
Actual Duration = Duration * Percent Complete

If you type a value in the Actual Duration field, Microsoft Project calculates the 
Remaining Duration and Percent Complete fields based on the above formulas. If you 
enter an actual duration greater than the scheduled duration, Microsoft Project 
changes scheduled duration to match the new actual duration and sets the remaining
duration to zero.

Because entering a value in the Actual Duration, Remaining Duration, or Percent 
Complete field automatically recalculates the other fields, you should enter a value in
only one of these fields for a task. If tasks are on schedule, you can use the Set 
Actual command on the Options menu to copy the scheduled fields for the tasks into 
the actual fields for the tasks.

For more information about using this field, see the "Tracking Progress" topic, and for 
more information about the relationship between planned, scheduled, and actual 
fields, see the "Fields" topic, both in the Microsoft Project User's Reference.

ACTUAL FINISH
Field #59
Entered

Date and time the task actually finished. Microsoft Project sets the Actual Finish field 
to the scheduled finish date if percent complete is 100. The field contains "NA" until 
you enter actual information or set percent complete to 100.

If tasks are on schedule, you can use the Set Actual command on the Options menu 
to copy the scheduled fields for the tasks into the actual fields for the tasks.

For more information about using this field, see the "Tracking Progress" topic, and for 
more information about the relationship between planned, scheduled, and actual 
fields, see the "Fields" topic, both in the Microsoft Project User's Reference.

ACTUAL START
Field #58
Entered

Date and time the task actually began. Microsoft Project sets the Actual Start field to 
the scheduled start date if the percent complete is greater than zero. The field 
contains "NA" until you enter a date in it or until you enter actual work or a percent 
complete value.



If tasks are on schedule, you can use the Set Actual command on the Options menu 
to copy the scheduled fields for the tasks into the actual fields for the tasks.

For more information about using this field, see the "Tracking Progress" topic, and for 
more information about the relationship between planned, scheduled, and actual 
fields, see the "Fields" topic, both in the Microsoft Project User's Reference.

ACTUAL WORK
Field #22
Calculated or Entered

Total amount of work that has been performed by the resources assigned to the task. 
The actual work is zero if you have not yet begun tracking the project. The actual 
work is the sum of the actual work performed by each resource assigned to the task. 
You can enter the actual work for each of the assigned resources in the resource 
assignment Actual Work fields at the bottom of the Task Form or Resource Form. If 
you will be entering actual work, choose the Preferences command from the Options 
menu, and change the Auto Track Resources option to No to prevent Microsoft Project
from recalculating the actual work as the percent complete changes. If you want 
Microsoft Project to calculate actual work for you based on the percent complete of 
the task, set the Auto Track Resources option to Yes.

If you enter a value in the Actual Work field for the task, Microsoft Project divides the 
actual work you enter among the assigned resources.

If tasks start and finish on schedule, you can use the Set Actual command on the 
Options menu to copy the scheduled fields for the tasks into the actual fields for the 
tasks.

For more information about using this field, see the "Scheduling Methods" and 
"Tracking Progress" topics, and for more information about the relationship between 
planned, scheduled, and actual fields, see the "Fields" topic, all in the Microsoft 
Project User's Reference.

BCWP
Field #86
Calculated

Budgeted Cost of Work Performed or the "earned value" of the work performed on the
task.

BCWP = Percent Complete * Planned Cost

Planned cost is also known as "Budget At Completion" or BAC. For example, if the 
planned cost for a task is $500 and the task is now 50 percent complete, the BCWP, 
or earned value, is $250. You can compare this value to the Actual Cost field, also 
known as the Actual Cost of Work Performed (ACWP), to determine if the task is on 
track in terms of cost. The CV (Earned Value Cost Variance) field shows the result of 
this comparison.

For more information, see the "Costs" and "Tracking Progress" topics in the Microsoft 
Project User's Reference.

BCWS



Field #85
Calculated

Budgeted Cost of Work Scheduled or the planned earned value of the task. Microsoft 
Project first determines the planned percent complete based on today's date and the 
task's planned start date and planned finish date. For example, if the task was 
planned to start on January 1, has a planned finish date of January 30, and today's 
date is January 16, the planned percent complete is 50%. Microsoft Project then 
multiplies the planned percent complete by the planned cost to calculate the BCWS, 
or planned earned value for the task. You can compare this value to the BCWP 
(Budgeted Cost of Work Performed) field to compare the value of the work you had 
planned to accomplish to the value of the work that has been completed. The SV 
(Earned Value Schedule Variance) field shows the result of this comparison.

For more information, see the "Costs" and "Tracking Progress" topics in the Microsoft 
Project User's Reference.

CONSTRAINT DATE
Field #68
Entered

Date used when you select a constraint type that requires a date. The constraints As 
Soon As Possible and As Late As Possible do not require a date.

For more information, see the "Constraints" topic in the Microsoft Project User's 
Reference.

CONSTRAINT TYPE
Field #91
Entered

Type of constraint--As Soon As Possible, As Late As Possible, Must Start On, Must 
Finish On, Start No Earlier Than, Start No Later Than, Finish No Earlier Than, Finish No 
Later Than--used in scheduling the task. All the constraints except As Soon As 
Possible and As Late As Possible require a date, which you enter in the Constraint 
Date field when scheduling the task. For example, if you select Must Start On as the 
constraint type and enter a constraint date of Sunday, January 7, Microsoft Project 
uses Sunday as the scheduled start date, even if the calendar being used lists 
Sunday as a nonworking day.

For more information, see the "Constraints" topic in the Microsoft Project User's 
Reference.

COST
Field #30
Calculated

Total scheduled (projected) cost for the task; also called Forecast At Completion 
(FAC). Cost is the sum of the costs of all work scheduled to be performed on the task 
by all assigned resources plus the fixed cost for the task.

For more information, see the "Costs" topic in the Microsoft Project User's Reference.

COST VARIANCE



Field #34
Calculated

The difference between the planned costs and the scheduled costs (current 
estimate). If the cost variance is negative, the cost is currently under the budgeted, 
or planned, amount; if the cost variance is positive, the task is over budget. When the
task is complete, this field shows the difference between planned costs and actual 
costs.

Cost Variance = Cost - Planned Cost 

For more information, see the "Costs" and "Tracking Progress" topics in the Microsoft 
Project User's Reference.

CREATED
Field #125
Calculated

Date this task was added to the project. The date comes from the current date in the 
Project Information dialog box.

CRITICAL
Field #82
Calculated

Indicates whether a task is critical or noncritical. The Critical field contains Yes if the 
task is critical and No if the task is not critical. A task is critical if the value in the Total
Slack field for that task is less than or equal to the Show As Critical If Slack <= option
in the Preferences dialog box. The Show As Critical If Slack <= option is initially zero, 
so if the task has zero slack or negative slack, the task is critical; if the task has some
slack, which means any value greater than zero in the Total Slack field, the task is not
critical.

For more information, see the "Critical Path" topic in the Microsoft Project User's 
Reference.

CV
Field #88
Calculated

Earned Value Cost Variance, which is the difference between the earned value of the 
work performed (Budgeted Cost of Work Performed or BCWP) and the Actual Cost 
field, also known as Actual Cost of Work Performed (ACWP).

CV = BCWP - Actual Cost 

For more information, see the "Costs" and "Tracking Progress" topics in the Microsoft 
Project User's Reference.

DELAY
Field #92
Entered

Amount of time that the scheduled start for a task will be delayed after its early start 



date. Microsoft Project enters a delay value when it shifts tasks during a resource 
leveling operation. You can type an elapsed amount of time followed by a duration 
abbreviation--em (elapsed minutes), eh (elapsed hours), ed (elapsed days), and ew 
(elapsed weeks). To return this field to zero, use the Remove Delay command on the 
Options menu.

For more information, see the "Leveling Resources" topic in the Microsoft Project 
User's Reference.

DURATION
Field #40
Calculated or Entered

Amount of time scheduled for the task. The field contains a number followed by a 
duration abbreviation: m (minutes), h (hours), d (days), w (weeks), em (elapsed 
minutes), eh (elapsed hours), ed (elapsed days), and ew (elapsed weeks). The default
is one day (1d).

If the task has a fixed duration regardless of the number of resources assigned to it, 
type the duration and select the Fixed check box on the Task Form, or type or select 
Yes in the Fixed field in a table. This is fixed-duration scheduling.

If you want the task duration to be adjusted based on the amount of work scheduled 
to be performed by the assigned resources, clear the Fixed check box, or type or 
select No in the Fixed field in a table. This is called resource-driven scheduling; 
Microsoft Project calculates the task duration as the longest amount of time required 
by any of the assigned resources to complete the assigned work. With resource-
driven scheduling, you can type a duration value as an initial estimate, but the 
duration will be recalculated when you enter work hours for the assigned resources in
the resource assignment fields. If you enter an elapsed duration, Microsoft Project 
changes the scheduling method for the task to fixed-duration.

For more information, see the "Durations" and "Scheduling Methods" topics in the 
Microsoft Project User's Reference.

DURATION VARIANCE
Field #45
Calculated

Difference between the planned duration of the task and the scheduled duration 
(current estimate). If the duration variance is negative, the task is scheduled to take 
less time than planned; if the duration variance is positive, the task is scheduled to 
take more time than planned.

Duration Variance = Duration - Planned Duration 

For more information, see the "Tracking Progress" topic in the Microsoft Project User's
Reference.

EARLY FINISH
Field #53
Calculated

Earliest date that the task could finish, based on the early start date and scheduled 



duration for the task. The early finish date is the same as the scheduled finish date 
unless there is a delay. This field is calculated by Microsoft Project when calculating 
the task's schedule.

EARLY START
Field #52
Calculated

Earliest date that the task could start, based on the scheduled start date and the 
delay value. The early start date is the same as the scheduled start date unless there
is a delay. This field is calculated by Microsoft Project when calculating the task's 
schedule.

Early Start = Scheduled Start - Delay 

FINISH1, FINISH2, FINISH3, FINISH4, and FINISH5
Field #s 61, 63, 65, 127, 129
Entered

Use these fields to enter additional finish dates you want stored separately for tasks. 
You can use these fields and the Start1, Start2, Start3, Start4, and Start5 fields to 
store interim plans or milestones for a task. These dates do not affect the project 
schedule. Entering additional finish and start dates is useful for noting important 
dates on the Gantt Chart. You can enter the information in the field or use the Set 
Plan command on the Options menu to save pairs of Start/Finish dates. These fields 
contain "NA" if no dates have been entered.

For more information, see the "Tracking Progress" topic in the Microsoft Project User's
Reference.

FINISH VARIANCE
Field #67
Calculated

Difference between the planned finish date of the task and the currently scheduled 
task finish date. If the finish variance is negative, the task is scheduled to finish 
earlier than planned; if the finish variance is positive, the task is scheduled to finish 
later than planned.

Finish Variance = Scheduled Finish - Planned Finish 

For more information, see the "Tracking Progress" topic in the Microsoft Project User's
Reference.

FIXED
Field #80
Entered

Specifies whether the duration of the task is fixed or resource-driven, which means 
that the duration is determined from the resource assignments. To make the task 
duration fixed, select the Fixed check box on the Task Form or type or select Yes in 
this field in a table. To allow durations to be adjusted based on resource assignments,
clear the Fixed check box or type or select No in this field. Whether tasks initially 
have a fixed or resource-driven duration is determined by the Default Duration Type 



option in the Preferences dialog box.

For more information, see the "Scheduling Methods" topic in the Microsoft Project 
User's Reference.

FIXED COST
Field #35
Entered

Contains the fixed cost for a task. This cost is added to the cost of the resources 
assigned to the task. Fixed cost is always prorated.

For more information, see the "Costs" topic in the Microsoft Project User's Reference.

FLAG1, FLAG2, FLAG3, FLAG4, FLAG5, FLAG6, FLAG7, FLAG8, FLAG9, 
FLAG10
Field #s 110, 111, 112, 113, 114, 115, 116, 117, 118, 119 
Entered

Use these fields to mark any task. They are used to roll up milestones on the Gantt 
bars. To mark a task, type yes in one of the flag fields. If you don't want a task 
marked, type no.

For more information, see the "Custom Fields" and "Gantt Chart" topics in the 
Microsoft Project User's Reference.

FREE SLACK
Field #93
Calculated

Amount of time that the task can be delayed without delaying any successor tasks. If 
the task has no successors, free slack is the amount of time that the task can be 
delayed without delaying the project finish date.

For more information, see the "Critical Path" topic in the Microsoft Project User's 
Reference.

ID
Field #90
Calculated

Number that indicates the position of the task with respect to the other tasks. As you 
enter tasks, they are numbered sequentially. This number is called the ID and is the 
unique identifier of the task. You can use duplicate task names because the ID 
number for each task is unique. When you insert, move, or delete a task, Microsoft 
Project automatically updates the ID numbers so the ID numbers always show the 
current order of the tasks.

LATE FINISH
Field #55
Calculated

Latest date that a task can finish without delaying the finish of the project. This field 
is calculated by Microsoft Project when calculating the task's schedule.



LATE START
Field #54
Calculated

Latest date that a task can start without delaying the finish of the project. This field is
calculated by Microsoft Project when calculating the task's schedule.

LINKED FIELDS
Field #122
Calculated

Indicates whether there are DDE links into the task. This field contains Yes if there are
links to the task, or No if there are no links.

For more information about linking task information, see the "Transferring 
Information" topic in the Microsoft Project User's Reference.

MARKED
Field #83
Entered

You can use the field for your own purposes, for example, to group tasks together for 
formatting. Microsoft Project does not assign any specific meaning to this field; 
however, you can use it to sort and filter tasks. To mark the task, type yes in this field
or select the Marked check box in the Task Edit Form dialog box. If you don't want the
task marked, type no or clear the Marked check box in the Task Edit Form dialog box.

MILESTONE
Field #81
Calculated or Entered

Indicates whether the task is a milestone task. If the task has a duration of zero, this 
field is set to Yes. If you want the task to appear as a milestone, regardless of its 
duration, type yes in this field or select the Milestone check box in the Task Edit Form 
dialog box. If you don't want the task to appear as a milestone, even if its duration is 
zero, type no or clear the Milestone check box in the Task Edit Form dialog box.

NAME
Field #1
Entered

Name of the task. You can enter any text or numbers into this field to describe the 
task. For more information, see the "Entering Tasks" topic in the Microsoft Project 
User's Reference.

NOTES
Field #14
Entered

Notes about the task. You can enter notes in this field or in the Notes box that can be 
added to the bottom of the Task Form. Longer notes must be viewed and edited on 
the Task Form.



For more information, see the "Notes" topic in the Microsoft Project User's Reference.

NUMBER1, NUMBER2, NUMBER3, NUMBER4, and NUMBER5
Field #s 140, 141, 142, 143, 144
Entered

You can enter any numeric information you want about the task in these fields and 
later sort or filter tasks using these fields. For example, you can show which 
department is responsible for each task by adding a number field in which you type 
the department code. You can then sort the tasks using the department code field to 
show how the tasks are grouped by department or to show the organizational 
breakdown of a project. These fields can be displayed in a table and on the PERT 
Chart.

For more information, see the "Custom Fields" topic in the Microsoft Project User's 
Reference.

OBJECTS
Field #121
Calculated

Number of objects attached to a task. An object is any information you have copied 
from another application and linked into Microsoft Project. For example, a graph you 
create with Microsoft Graph and attach to a summary task is an object. You can view 
objects in the Objects box that can be added to the bottom of the Task Form.

For more information about objects, see the "Transferring Information" and "Microsoft 
Graph" topics in the Microsoft Project User's Reference.

OUTLINE LEVEL
Field #3
Calculated

Level of the task in an outline. This field contains a number, 1 through 10, with 1 the 
highest level and 10 the lowest.

OUTLINE NUMBER
Field #99
Calculated

Number of the task in an outline. Same as the outline number you see when you 
choose the Outline command from the Format menu, and select the Outline Number 
check box.

For more information, see the "Outlining" topic in the Microsoft Project User's 
Reference.

PERCENT (%) COMPLETE
Field #44
Calculated or Entered

Percentage of the task's duration that has been completed. If you type a value in the 
Percent Complete field, Microsoft Project automatically calculates actual duration and
remaining duration. If the Auto Track Resources option in the Preferences dialog box 



is set to Yes, Microsoft Project also calculates actual work and remaining work, and 
then actual cost and remaining cost.

If you type a value in the Remaining Duration field or Actual Duration field, percent 
complete is calculated using the following formulas:

Percent Complete = ((Duration - Remaining Duration) / Duration) * 100
Percent Complete = (Actual Duration / Duration) * 100

Because entering a value in the Actual Duration, Remaining Duration, or Percent 
Complete field automatically recalculates the other fields, you should enter a value in
only one of these fields for a task. If the Percent Complete field is set to a value 
greater than zero, the Actual Start field is set to the scheduled start date if you have 
not yet entered an actual start date. If the Percent Complete field is set to 100, the 
Actual Finish field is set to the scheduled finish date.

For more information, see the "Tracking Progress" topic in the Microsoft Project User's
Reference.

PERCENT (%) WORK COMPLETE
Field #25
Calculated or Entered

Percentage of the task's work that has been completed. If you type a value in the % 
Work Complete field, Microsoft Project automatically calculates actual work and 
remaining work. If you are tracking work using this field, you should change the Auto 
Track Resources setting in the Preferences dialog box to No so that Microsoft Project 
won't calculate work for you based on the percent complete for duration.

If you type a value in the Remaining Work field or Actual Work field, percent work 
complete is calculated using the following formulas:

% Work Complete = ((Work - Remaining Work) / Work) * 100 
% Work Complete = (Actual Work / Work) * 100 

Because entering a value in the Actual Work, Remaining Work, or % Work Complete 
field automatically recalculates the other fields, you should enter a value in only one 
of these fields for a task.

For more information, see the "Tracking Progress" topic in the Microsoft Project User's
Reference.

PLANNED COST
Field #31
Calculated or Entered

Total planned costs for the task; also called Budgeted At Completion (BAC). The 
planned cost is calculated as the sum of the planned costs of all the assigned 
resources plus any fixed cost for the task. You can use the Set Plan command on the 
Options menu to copy the scheduled fields for tasks into the planned fields for the 
tasks.

For more information on using this field, see the "Costs" topic, and for more 
information about the relationship between planned, scheduled, and actual fields, see



the "Fields" topic, both in the Microsoft Project User's Reference.

PLANNED DURATION
Field #41
Entered

Amount of time planned for the task. The field contains a number followed by a 
duration abbreviation: m (minutes), h (hours), d (days), w (weeks), em (elapsed 
minutes), eh (elapsed hours), ed (elapsed days), and ew (elapsed weeks). You can 
use the Set Plan command on the Options menu to copy the scheduled fields for 
tasks into the planned fields for the tasks.

For more information about using this field, see the "Tracking Progress" topic, and for 
more information about the relationship between planned, scheduled, and actual 
fields, see the "Fields" topic, both in the Microsoft Project User's Reference.

PLANNED FINISH
Field #57
Entered

Planned finish date of the task. The field contains "NA" until you enter information. 
You can use the Set Plan command on the Options menu to copy the scheduled fields
for tasks into the planned fields for the tasks.

For more information about using this field, see the "Tracking Progress" topic, and for 
more information about the relationship between planned, scheduled, and actual 
fields, see the "Fields" topic, both in the Microsoft Project User's Reference.

PLANNED START
Field #56
Entered

Planned start date of the task. The field contains "NA" until you enter information. 
You can use the Set Plan command on the Options menu to copy the scheduled fields
for tasks into the planned fields for the tasks.

For more information about using this field, see the "Tracking Progress" topic, and for 
more information about the relationship between planned, scheduled, and actual 
fields, see the "Fields" topic, both in the Microsoft Project User's Reference.

PLANNED WORK
Field #21
Calculated or Entered

Total amount of work planned to be performed by all resources assigned to the task. 
The planned work is calculated as the sum of the planned work of all assigned 
resources. If you type a value for planned work, Microsoft Project divides the planned 
work among the assigned resources. You can use the Set Plan command on the 
Options menu to copy the scheduled fields for tasks into the planned fields for the 
tasks.

For more information about using this field, see the "Scheduling Methods" and 
"Tracking Progress" topics, and for more information about the relationship between 
planned, scheduled, and actual fields, see the "Fields" topic, all in the Microsoft 



Project User's Reference.

PREDECESSORS
Field #70
Entered

List of tasks that the task depends on. Each predecessor is linked to the task by a 
specific type of relationship and a lead or lag time. On the Task Form, the ID, Name, 
Type, and Lag for each predecessor is displayed in a separate row. In a table or PERT 
node, all the predecessors appear in a single field and are separated by the list 
separator character. Each predecessor is represented by its ID number, and may be 
followed by a relationship and the lead or lag time. For example, "14FS+3d" means 
that task 14 is a predecessor, with a finish-to-start relationship and a 3-day lag time. 
To enter lead time, type a negative number.

The relationship types for predecessors are FS (finish-to-start), FF (finish-to-finish), SS
(start-to-start), and SF (start-to-finish). If you enter only the task ID number, Microsoft
Project assumes a finish-to-start relationship with zero lag time. You can use the Link 
Tasks command on the Edit menu to link the selected tasks with finish-to-start 
relationships and zero lag time.

If your list of predecessors ends with an ellipsis (...), the list is too long to be edited in
the entry bar. To edit or delete a predecessor, use the predecessors fields at the 
bottom of the Task Form.

For more information, see the "Lead and Lag Time" and "Task Relationships" topics in 
the Microsoft Project User's Reference.

PRIORITY
Field #95
Entered

Indicates how readily a task is delayed during leveling. Those tasks with a priority of 
Do Not Level are not delayed when Microsoft Project levels tasks with overallocated 
resources.

For more information, see the "Leveling Resources" topic in the Microsoft Project 
User's Reference.

PROJECT
Field #97
Calculated

Name of the project containing the task. You can sort and filter on this field when you 
are viewing multiple projects in one window.

For more information, see the "Multiple Projects" topic in the Microsoft Project User's 
Reference.

REMAINING COST
Field #33
Calculated or Entered

Total costs that will be incurred to complete the task as currently scheduled. The 



remaining cost equals the cost if you have not yet begun tracking the project. The 
remaining cost for a task is calculated as the sum of the remaining costs of all the 
assigned resources plus the remaining fixed cost for the task.

For more information, see the "Costs" and "Tracking Progress" topics in the Microsoft 
Project User's Reference.

REMAINING DURATION
Field #43
Calculated or Entered

Length of time required to complete the unfinished portion of the task.

If you type a value in the Actual Duration field or Percent Complete field, remaining 
duration is calculated using the following formulas:

Remaining Duration = Duration - Actual Duration
Remaining Duration = Duration - (Duration * Percent Complete)

If you type a value in the Remaining Duration field, Microsoft Project calculates the 
actual duration and percent complete. If you increase remaining duration, Microsoft 
Project increases duration to match the sum of the remaining duration and actual 
duration and leaves the actual duration unchanged. Because typing a value in the 
Remaining Duration, Actual Duration, or Percent Complete field automatically 
recalculates the other fields, you should enter a value in only one of these fields for a
task.

For more information, see the "Tracking Progress" topic in the Microsoft Project User's
Reference.

REMAINING WORK
Field #23
Calculated or Entered

Total amount of work that has yet to be performed on a task by all assigned 
resources. The remaining work equals work if you have not yet begun tracking the 
project. The remaining work is calculated as the sum of the remaining work of the 
assigned resources. If you type a value in the Remaining Work field, Microsoft Project 
divides the remaining work you enter among the assigned resources.

For more information, see the "Scheduling Methods" and "Tracking Progress" topics in
the Microsoft Project User's Reference.

RESOURCE INITIALS
Field #73
Entered

Abbreviation that stands for the resource assigned to the task. Each resource 
assigned to the task can be listed by its initials in the Resource Initials field rather 
than by its entire name. The Resource Initials field can be used as a quick way to 
enter or view resource assignments.

RESOURCE NAMES
Field #72



Entered

Names of the resources assigned to this task. In a table, each resource is represented
by its name, followed by the number of units of the resource used by the task. The 
number of units is shown in brackets ([ ]). If the number of units is 1, only the 
resource name is shown. For example, "Plumber, Electrician[3]" indicates that one 
plumber and three electricians are assigned.

If your list of resources ends with an ellipsis (...), the list is too long to be edited in the
entry bar. To edit or delete a resource assignment, use the resources fields at the 
bottom of the Task Form.

For more information, see the "Assigning Resources" topic in the Microsoft Project 
User's Reference.

RESUME
Field #151
Calculated

Date on which a task is scheduled to resume. This field contains "NA" if you have not 
used the reschedule remaining duration button on the tool bar or the Set Actual 
command on the Options menu to reschedule the remaining duration for a task. It 
also contains "NA" if the Auto Task Splitting option in the Preferences dialog box is set
to No.

For more information, see the "Tracking Progress" topic in the Microsoft Project User's
Reference.

RESUME NO EARLIER THAN
Field #152
Entered

Date on which a task is scheduled to resume. When you use the Set Actual command
on the Options menu to enter actual information for the task, you can specify that the
remaining work on a task be rescheduled to continue no earlier than the date in this 
field. This field contains "NA" if you have not used the reschedule remaining duration 
button on the tool bar or the Set Actual command on the Options menu to reschedule
the remaining duration for a task. It also contains "NA" if the Auto Task Splitting 
option in the Preferences dialog box is set to No.

For more information, see the "Tracking Progress" topic in the Microsoft Project User's
Reference.

ROLLUP
Field #84
Entered

Indicates whether subordinate task dates are to be rolled up to appear on the 
summary task bar. If the Rollup field is set to Yes for the summary task and for each 
subordinate task whose information you want included on the summary task bar, task
dates are rolled up.

For more information, see the "Gantt Chart" topic in the Microsoft Project User's 
Reference.



SCHEDULED FINISH
Field #51
Calculated or Entered

Date the task is scheduled to finish. If you do not type a scheduled finish date, 
Microsoft Project calculates it based on such things as relationships, calendars, and 
the scheduling method. If you type a scheduled finish date, Microsoft Project 
automatically enters a Must Finish On constraint and uses the date you type as the 
constraint date. If you enter an actual finish date that is different from the scheduled 
finish date, Microsoft Project changes the scheduled finish date to match the actual 
finish date.

For more information about using this field, see the "Tracking Progress" topic, and for 
more information about the relationship between planned, scheduled, and actual 
fields, see the "Fields" topic, both in the Microsoft Project User's Reference.

SCHEDULED START
Field #50
Calculated or Entered

Date the task is scheduled to start. If you do not type a scheduled start date, 
Microsoft Project calculates a start date based on such things as relationships, 
calendars, and the scheduling method. If you type a scheduled start date, Microsoft 
Project automatically enters a Must Start On constraint and uses the date you type as
the constraint date. If you enter an actual start date that is different from the 
scheduled start date, Microsoft Project changes the scheduled start date to match the
actual start date.

For more information about using this field, see the "Tracking Progress" topic, and for 
more information about the relationship between planned, scheduled, and actual 
fields, see the "Fields" topic, both in the Microsoft Project User's Reference.

START1, START2, START3, START4, and START5
Field #s 60, 62, 64, 126, 128
Entered

Use these fields to enter additional start dates you want stored separately for tasks. 
You can use these fields and the Finish1, Finish2, Finish3, Finish4, and Finish5 fields to
store interim plans or milestones for a task. These dates do not affect the project 
schedule. Entering additional start and finish dates is useful for noting important 
dates on the Gantt Chart. You can enter the information in the field or use the Set 
Plan command on the Options menu to save pairs of Start/Finish dates. These fields 
contain "NA" if no dates have been entered.

For more information, see the "Tracking Progress" topic in the Microsoft Project User's
Reference.

START VARIANCE
Field #66
Calculated

Difference between the planned start date of the task and the currently scheduled 
task start date. If the start variance is negative, the task is scheduled to start earlier 



than planned; if the start variance is positive, the task is scheduled to start later than
planned.

Start Variance = Scheduled Start - Planned Start

For more information, see the "Tracking Progress" topic in the Microsoft Project User's
Reference.

STOP
Field #150
Calculated

Date on which you last used the Set Actual command on the Options menu to enter 
actual information for the task. This field contains "NA" if you have not used the 
reschedule remaining duration button on the tool bar or the Set Actual command on 
the Options menu to reschedule the remaining duration for a task. It also contains 
"NA" if the Auto Task Splitting option in the Preferences dialog box is set to No.

For more information, see the "Tracking Progress" topic in the Microsoft Project User's
Reference.

SUBPROJECT FILE
Field #96
Entered

Name of another project to be used as a subproject in this project; includes the path 
and filename of the subproject. A subproject is represented by a single task in the 
master project, the duration of which is the duration of the subproject.

For more information, see the "Subprojects" topic in the Microsoft Project User's 
Reference.

SUCCESSORS
Field #71
Entered

List of tasks that depend on the task. Each successor is linked to the task by a 
specific type of relationship and a lead or lag time. On the Task Form, the ID, Name, 
Type, and Lag for each successor is displayed in a separate row. In a table or PERT 
node, all of the successors appear in a single field and are separated by the list 
separator character. Each successor is represented by its ID number, and may be 
followed by a relationship and the lead or lag time. For example "14FS+3d" means 
that task 14 is a successor, with a finish-to-start relationship and a 3-day lag time.

The relationship types for successors are FS (finish-to-start), FF (finish-to-finish), SS 
(start-to-start), and SF (start-to-finish). If you enter only the task ID number, Microsoft
Project assumes a finish-to-start relationship with zero lag time.

If your list of successors ends with an ellipsis (...), the list is too long to be edited in 
the entry bar. To edit or delete a successor, use the successors fields at the bottom of
the Task Form.

For more information, see the "Lead and Lag Time" and "Task Relationships" topics in 
the Microsoft Project User's Reference.



SUMMARY
Field #120
Calculated

Indicates whether the task is a summary task. If the task is a summary task, the 
Summary field contains Yes. A task is a summary task if it has tasks indented 
beneath it.

For more information, see the "Outlining" topic in the Microsoft Project User's 
Reference.

SV
Field #87
Calculated

Earned Value Schedule Variance, which is the difference between the earned value of 
the work performed (Budgeted Cost of Work Performed or BCWP) and the earned 
value of the work that had been planned to be performed (Budgeted Cost of Work 
Scheduled or BCWS). The schedule variance is expressed in the currency used, the 
same units used in the CV (Earned Value Cost Variance) field, so that the earned 
value cost and schedule variances can be plotted on the same graph.

SV = BCWP - BCWS

For more information, see the "Costs" and "Tracking Progress" topics in the Microsoft 
Project User's Reference.

TEXT1, TEXT2, TEXT3, TEXT4, TEXT5, TEXT6, TEXT7, TEXT8, TEXT9, and 
TEXT10
Field #s 4, 5, 6, 7, 8, 9, 10, 11, 12, 13
Entered

You can enter in these fields any information you want about the task and later sort 
or filter tasks using these fields. For example, you can show which department is 
responsible for each task by adding a text field in which you type the department 
code. You can then sort the tasks using the department code field to show how the 
tasks are grouped by department or to show the organizational breakdown of a 
project. This text can be displayed in a table and on the PERT Chart.

For more information, see the "Custom Fields" topic in the Microsoft Project User's 
Reference.

TOTAL SLACK
Field #94
Calculated

Amount of time a task can be delayed without delaying the project finish date. Total 
slack can be negative or positive. Positive slack is the amount of time that the task 
can be delayed without delaying the project finish date. Negative slack is the amount
of time that must be saved so that the project end date is not delayed. Negative 
slack indicates that there is not enough time scheduled for the task and is usually 
caused by constraint dates or task relationships.



For more information, see the "Critical Path" topic in the Microsoft Project User's 
Reference.

UNIQUE ID
Field #98
Calculated

Number assigned by Microsoft Project to each task when it is created. When a task is 
deleted from the project, the unique ID assigned to the deleted task is not 
reassigned.

UNIQUE ID PREDECESSORS
Field #74
Entered

List of tasks that the task depends on, using the unique ID for each task instead of 
the ID. For more information about predecessors, see the "Task Relationships" topic in
the Microsoft Project User's Reference.

UNIQUE ID SUCCESSORS
Field #75
Entered

List of tasks that depend on the task, using the unique ID for each task instead of the 
ID. For more information about successors, see the "Task Relationships" topic in the 
Microsoft Project User's Reference

WBS
Field #2
Calculated or Entered

Work Breakdown Structure code. This field contains an alphanumeric code that can 
be used to represent the task's position within the hierarchical structure of the 
project. The default WBS code is the task's outline number. You can type your own 
custom WBS code. This is useful if your company uses a standard WBS code system 
for project management. If you delete the code you entered for a task, the field 
returns to the outline number.

For more information, see the "Outlining" topic in the Microsoft Project User's 
Reference.

WORK
Field #20
Calculated or Entered

Total amount of work scheduled to be performed by all resources assigned to the 
task. Work is calculated as the sum of the work that all assigned resources are 
scheduled to perform on the task. You type the work for each of the assigned 
resources in the resource assignment Work field at the bottom of the Task Form or 
Resource Form. If you type a value in the Work field for the task, Microsoft Project 
divides the work you enter among the assigned resources.

For more information, see the "Assigning Resources" and "Scheduling Methods" 
topics in the Microsoft Project User's Reference.



WORK VARIANCE
Field #24
Calculated

Difference between the planned work for the task and the currently scheduled work. 
If the work variance is negative, less work is scheduled for the task than was 
planned; if the work variance is positive, more work is scheduled for the task than 
was planned.

Work Variance = Work - Planned Work 

For more information, see the "Tracking Progress" topic in the Microsoft Project User's
Reference.

RESOURCE FIELDS

The resource fields are all those you can use on the resource views, such as the 
Resource Sheet and Resource Usage view. These fields show the total information for 
each resource but not the resource information for individual tasks. The fields are 
listed in alphabetic order. For information about the fields at the bottom of the 
Resource Form and Resource Name Form that show resource information per task 
assignment, see "Resource Assignment Fields" later in this document.

Resource fields that show totals, such as the Work field and Cost field, sum the values
from all open projects for all assignments made using the same resource pool.

ACCRUE AT
Field #45
Entered

When actual costs should be charged or accrued--can be Start, End, or Prorated. If 
you select the Start option, actual costs are incurred as soon as a task starts, which is
when a date is entered in the Actual Start field. If you select the End option, actual 
costs are not incurred until remaining work is zero. If you select the Prorated option, 
the costs accrue as work is scheduled to occur, and are calculated by multiplying unit
costs by work.

For more information, see the "Costs" topic in the Microsoft Project User's Reference.

ACTUAL COST
Field #32
Calculated

Sum of the costs incurred for the work already performed by this resource in all open 
projects using the same resource pool. This field contains zero if you have not yet 
incurred costs in any of the open projects.

For more information about using this field, see the "Costs" and "Tracking Progress" 
topics, and for more information about the relationship between planned, scheduled, 
and actual fields, see the "Fields" topic, all in the Microsoft Project User's Reference.



ACTUAL WORK
Field #22
Calculated

Total amount of work that has already been performed by this resource in all open 
projects using the same resource pool. This field contains zero if you have not yet 
begun tracking the progress of any of the open projects.

For more information about using this field, see the "Tracking Progress" topic, and for 
more information about the relationship between planned, scheduled, and actual 
fields, see the "Fields" topic, both in the Microsoft Project User's Reference.

BASE CALENDAR
Field #48
Entered

Base calendar to use for this resource. The default is the Standard calendar.

For more information, see the "Calendars" topic in the Microsoft Project User's 
Reference.

CODE
Field #4
Entered

Use this field to enter a code that identifies or is associated with particular resources.
You can use this field for sorting and filtering resources. For example, you may want 
to assign cost-center codes to certain resources and then filter the resources to show 
only those resources assigned to a particular cost center.

For more information, see the "Resource Form" and "Resource Sheet" topics in the 
Microsoft Project User's Reference.

COST
Field #30
Calculated

Total scheduled costs for the resource for all assignments in all open projects that use
the same resource pool. If the resource is assigned in a project that is not open but 
uses the same resource pool, costs from that project are not shown in this field nor in 
the Actual Cost and Remaining Cost fields for the resource until you open that 
project.

For more information, see the "Costs" topic in the Microsoft Project User's Reference.

COST PER USE
Field #44
Entered

Fixed cost per use of each resource unit. This cost is added each time a unit of a 
resource is assigned to a task. This is a fixed cost that doesn't vary with the time that
the resource is used, such as a delivery charge.

For more information, see the "Costs" topic in the Microsoft Project User's Reference.



COST VARIANCE
Field #34
Calculated

Difference between the planned cost for the resource and the currently scheduled 
resource cost. If the cost variance is negative, the cost for the resource is currently 
under the budgeted, or planned, amount; if the cost variance is positive, the resource
cost is over budget.

Cost Variance = Cost - Planned Cost 

For more information, see the "Costs" and "Tracking Progress" topics in the Microsoft 
Project User's Reference.

GROUP
Field #3
Entered

Use this field to enter the name of the group to which the resource belongs. You can 
use this field for sorting and filtering resources. For example, you could apply a filter 
that displays only resources that belong to the group Plumbers; resources in other 
groups, such as Construction and Managers, would not be displayed.

For more information, see the "Resource Form" and "Resource Sheet" topics in the 
Microsoft Project User's Reference.

ID
Field #40
Calculated

Number that indicates the position of the resource with respect to the other 
resources. As you enter resources, they are numbered sequentially. This number is 
called the ID and is the unique identifier of the resource. You can use duplicate 
resource names because the ID number for each resource is unique. When you insert,
move, or delete a resource, Microsoft Project automatically updates the ID numbers 
so the ID numbers always show the current order of the resources.

For more information, see the "Resource Sheet" topic in the Microsoft Project User's 
Reference.

INITIALS
Field #2
Entered

This field serves as a substitute for the Name field, so you can type abbreviations 
instead of the entire name to identify resources. If you do not enter initials, this field 
shows the first letter of the resource name.

For more information, see the "Resource Form" and "Resource Sheet" topics in the 
Microsoft Project User's Reference.

LINKED FIELDS
Field #51



Calculated

Indicates whether there are DDE links into the resource. This field contains Yes if 
there are links to the resource, or No if there are no links.

For more information about linking resource information, see the "Transferring 
Information" topic in the Microsoft Project User's Reference.

MAX UNITS
Field #41
Entered

Maximum number of units of this resource that are available. If more than the 
maximum units are allocated to tasks, Microsoft Project considers this resource to be 
overallocated, and the Overallocated field is set to Yes. The default for Max Units is 1.

For more information, see the "Resource Form" and "Resource Sheet" topics in the 
Microsoft Project User's Reference.

NAME
Field #1
Entered

Name of the resource. You can enter any text or numbers into this field.

For more information, see the "Resource Form" and "Resource Sheet" topics in the 
Microsoft Project User's Reference.

NOTES
Field #10
Entered

Notes about the resource. You can enter notes in this field or in the Notes box that 
can be added to the bottom of the Resource Form. Longer notes must be viewed and 
edited on the Resource Form.

For more information, see the "Notes" topic in the Microsoft Project User's Reference.

OBJECTS
Field #50
Calculated

Number of objects attached to a resource. An object is any information you have 
copied from another application and linked into Microsoft Project. For example, a 
graph you create with Microsoft Graph and attach to a resource is an object. You can 
view objects in the Objects box that can be added to the bottom of the Resource 
Form.

For more information about objects, see the "Transferring Information" and "Microsoft 
Graph" topics in the Microsoft Project User's Reference.

OVERALLOCATED
Field #46
Calculated



Indicates whether the resource is overallocated. This field contains Yes if the resource
is overallocated. A resource is overallocated if the value in the Peak field is greater 
than the value in the Max Units field.

For more information, see the "Leveling Resources" topic in the Microsoft Project 
User's Reference.

OVERTIME RATE
Field #43
Entered

Rate of pay for overtime work performed by this resource. The default rate is 
determined by the Default Overtime Rate option in the Preferences dialog box. Type a
number followed by a slash and a time unit. For example, type $15/h to enter a rate 
of $15.00 per hour. If you don't type a slash and time unit, hours is used. You enter 
overtime work hours for a resource in the resource assignment fields at the bottom of
the Task Form or Resource Form.

For more information, see the "Costs" topic in the Microsoft Project User's Reference.

OVERTIME WORK
Field #24
Calculated

Total amount of overtime work that is paid at the overtime rate and scheduled to be 
performed by this resource in all open projects using the same resource pool.

For more information, see the "Scheduling Methods" topic in the Microsoft Project 
User's Reference.

PEAK
Field #47
Calculated

Greatest number of units of this resource assigned at any one time to the tasks in the
open projects using the same resource pool. When displaying peak units on the 
Resource Graph or Resource Usage view, the value in this field corresponds to the 
highest point shown on the Resource Graph or the value displayed on the Resource 
Usage view.

For more information, see the "Resource Graph" and "Resource Usage View" topics in 
the Microsoft Project User's Reference.

PERCENT (%) WORK COMPLETE
Field #26
Calculated

Percentage of the resource's work that has been completed.

% Work Complete = (Actual Work / Work) * 100

For more information, see the "Tracking Progress" topic in the Microsoft Project User's
Reference.



PLANNED COST
Field #31
Calculated

Total planned cost for the resource for all assignments in all open projects that use 
the same resource pool. This is the baseline cost for the resource. This field is 
updated when you use the Set Plan command on the Options menu to copy the 
scheduled fields to the planned fields for the tasks to which this resource is assigned.

For more information about using this field, see the "Costs" topic, and for more 
information about the relationship between planned, scheduled, and actual fields, see
the "Fields" topic, both in the Microsoft Project User's Reference.

PLANNED WORK
Field #21
Calculated

Total amount of planned work to be performed by this resource in all open projects 
using the same resource pool. This field is updated when you use the Set Plan 
command on the Options menu to copy the scheduled fields to the planned fields for 
the tasks to which this resource is assigned.

For more information about using this field, see the "Tracking Progress" topic, and for 
more information about the relationship between planned, scheduled, and actual 
fields, see the "Fields" topic, both in the Microsoft Project User's Reference.

REMAINING COST
Field #33
Calculated

Total cost that will be incurred in completing the work that has yet to be performed 
by this resource in all open projects. This field equals the resource Cost field if you 
have not yet incurred costs in any of the open projects using the same resource pool.

For more information, see the "Costs" and "Tracking Progress" topics in the Microsoft 
Project User's Reference.

REMAINING WORK
Field #23
Calculated

Total amount of work that has yet to be performed by this resource in all open 
projects using the same resource pool. This field equals the resource Work field if you
have not yet begun tracking the progress of any of the open projects using the same 
resource pool.

For more information, see the "Tracking Progress" topic in the Microsoft Project User's
Reference.

STANDARD RATE
Field #42
Entered



Rate of pay for standard, nonovertime work performed by this resource. The default 
rate is determined by the Default Standard Rate option in the Preferences dialog box. 
Type a number followed by a slash and a time unit. For example, type $15/h to enter 
a rate of $15.00 per hour. If you don't type a slash and time unit, hours is used.

For more information, see the "Costs" topic in the Microsoft Project User's Reference.

TEXT1, TEXT2, TEXT3, TEXT4, and TEXT5
Field #s 5, 6, 7, 8, 9
Entered

You can enter any information you want about the resource in these fields and later 
sort or filter resources using these fields. For example, you can include the manager 
to whom the resource reports by adding a text field in which you type the manager's 
name.

For more information, see the "Custom Fields" topic in the Microsoft Project User's 
Reference.

UNIQUE ID
Field #49
Calculated

Number assigned by Microsoft Project to each resource when it is created. When a 
resource is deleted from the project, the unique ID assigned to the deleted resource 
is not reassigned.

WORK
Field #20
Calculated

Total amount of work scheduled to be performed by this resource in all open projects 
that use the same resource pool. This field shows the total work, or "person-hours," 
scheduled for the resource.

If this resource is assigned in a project that is not open but uses the same resource 
pool, work from that project is not shown in this field or in the Actual Work or 
Remaining Work fields for the resource until you open that project.

For more information, see the "Assigning Resources" and "Scheduling Methods" 
topics in the Microsoft Project User's Reference.

WORK VARIANCE
Field #25
Calculated

Difference between the planned work for the resource and the currently scheduled 
work. If the work variance is negative, less work is scheduled for the resource than 
was planned; if the work variance is positive, more work is scheduled for the resource
than was planned.

Work Variance = Work - Planned Work 

For more information, see the "Tracking Progress" topic in the Microsoft Project User's



Reference.

RESOURCE ASSIGNMENT FIELDS

The resource assignment fields appear at the bottom of the Task Forms and Resource 
Forms only and show information about each resource assignment. You can change 
which resource assignment fields appear at the bottom of the forms by choosing a 
command from the Format menu while the Task Form, Task Details Form, Task Name 
Form, Resource Form, or Resource Name Form is active. Each shows a different set of 
resource assignment fields.

Information in the resource assignment fields ties the resources and tasks together 
so Microsoft Project can calculate additional information about the project.

The resource assignment fields are described in this section in alphabetic order. 
These fields show the information for each resource assigned to each task. For 
resource or task totals, use the resource fields or task fields described earlier in this 
topic.

ACTUAL COST
Calculated or Entered

Costs incurred for work already performed by this resource for this task. This field 
contains $0 if you have not yet incurred costs. Microsoft Project calculates the value 
for the actual cost for each assigned resource as the actual work changes, depending
on the setting of the assigned resource's Accrue At field. When the percent complete 
reaches 100, you can then enter an actual cost that won't be recalculated.

If tasks are on schedule, you can use the Set Actual command on the Options menu 
to copy the scheduled fields for the tasks, including their resource assignments, into 
the actual fields for the tasks.

Actual Cost = Cost - Remaining Cost

For more information about using this field, see the "Costs" and "Tracking Progress" 
topics, and for more information about the relationship between planned, scheduled, 
and actual fields, see the "Fields" topic, all in the Microsoft Project User's Reference.

ACTUAL WORK
Calculated or Entered

Amount of work that has already been performed by this resource for this task. This 
field contains zero if you have not yet begun tracking the project. If the Auto Track 
Resources option in the Preferences dialog box is set to Yes, Microsoft Project 
calculates the value for actual work for each assigned resource based on the percent 
complete for the task. If you will be entering actual work, set the Auto Track 
Resources option in the Preferences dialog box to No to prevent Microsoft Project 
from recalculating the actual work as the percent complete changes; if actual work is 
zero when the percent complete reaches 100, the scheduled work value is copied 
into actual work for the assigned resources.

If tasks are on schedule, you can use the Set Actual command on the Options menu 
to copy the scheduled fields for the tasks, including the start and finish dates for 



each resource assignment, into the actual fields for the tasks.

Actual Work = Work - Remaining Work

For more information about using this field, see the "Assigning Resources" and 
"Tracking Progress" topics, and for more information about the relationship between 
planned, scheduled, and actual fields, see the "Fields" topic, all in the Microsoft 
Project User's Reference.

COST
Calculated or Entered

Scheduled cost for this resource assignment. Cost is calculated based on the work 
and Standard Rate, Overtime Rate, Cost Per Use, and Accrue At fields for the resource
and the amount of work that the resource is assigned to perform on this task. If the 
Units field is zero, you can enter a fixed cost in this field. Entering a fixed cost for a 
resource assignment is useful if the resource is paid a fixed fee in a lump sum for 
completing work on the task.

Cost = Actual Cost + Remaining Cost 

For more information, see the "Costs" and "Tracking Progress" topics in the Microsoft 
Project User's Reference.

DELAY
Entered

Amount of time the resource waits to begin work on a task assignment. For example, 
if a task is eight hours long, but a particular resource only needs to work the last two 
hours on the task, you would type 6h in the Delay field so that the resource is not 
scheduled until the last two hours.

For more information, see the "Assigning Resources" topic in the Microsoft Project 
User's Reference.

ID
Calculated or Entered

On the Task Form, this field contains the ID number of the resource assigned to the 
current task. You can assign resources by typing the resource's ID number in this 
field; the resource name is automatically entered in the Resource Name field. If you 
type the resource name in the Resource Name field, the corresponding ID is 
automatically entered.

On the Resource Form, this field contains the ID number of the task to which the 
resource is assigned. You cannot edit or enter the ID number on the Resource Form.

OVERTIME WORK
Entered

Work that is not included when the schedule is calculated, but will be performed by 
this resource for this task and charged at the overtime rate. For example, if a 
resource is assigned 32 hours of work, 8 hours of which is overtime work, only the 24 
hours of standard work is scheduled. When tracking progress, costs for overtime work



are incurred last.

For more information, see the "Scheduling Methods" topic in the Microsoft Project 
User's Reference.

PLAN COST
Entered

Planned costs for work to be performed by this resource on this task. You can use the 
Set Plan command on the Options menu to copy the scheduled fields for tasks, 
including their resource assignments, into the planned fields for the tasks.

For more information about using this field, see the "Costs" and "Tracking Progress" 
topics, and for more information about the relationship between planned, scheduled, 
and actual fields, see the "Fields" topic, all in the Microsoft Project User's Reference.

PLAN WORK
Entered

Amount of work planned to be performed by this resource on this task. You can use 
the Set Plan command on the Options menu to copy the scheduled fields for tasks, 
including their resource assignments, into the planned fields for the tasks.

For more information about using this field, see the "Tracking Progress" topic, and for 
more information about the relationship between planned, scheduled, and actual 
fields, see the "Fields" topic, both in the Microsoft Project User's Reference.

PROJECT
Calculated

This field appears on the Resource Form only and is the name of the project 
containing the task to which the resource is assigned.

For more information, see the "Resource Form" topic in the Microsoft Project User's 
Reference.

REMAINING COST
Calculated or Entered

Cost that will be incurred in completing the work that has yet to be performed by this
resource on this task. Remaining Cost equals Cost if you have not yet incurred costs. 
Microsoft Project calculates the remaining cost based on the remaining work.

For more information, see the "Costs" and "Tracking Progress" topics in the Microsoft 
Project User's Reference.

REMAINING WORK
Calculated or Entered

Amount of work yet to be performed by this resource on this task. Remaining Work 
equals Work if no work has occurred. You can enter the remaining work for the 
assigned resource or let Microsoft Project calculate the remaining work based on the 
percent complete. If you will be entering actual or remaining work, set the Auto Track 
Resources option in the Preferences dialog box to No to prevent Microsoft Project 



from recalculating the remaining work as the percent complete changes.

Remaining Work = Work - Actual Work 

For more information, see the "Assigning Resources" and "Tracking Progress" topics in
the Microsoft Project User's Reference.

RESOURCE NAME
Calculated or Entered

This field appears only on the Task Form and is the name of the assigned resource. If 
you enter the resource ID number, the name is automatically entered in this field.

For more information, see the "Resource Form" topic in the Microsoft Project User's 
Reference.

SCHEDULED FINISH
Calculated

Date the resource is scheduled to finish work on this task. The scheduled finish date 
takes into consideration the resource calendar.

For more information about using this field, see the "Scheduling Methods" topic, and 
for more information about the relationship between planned, scheduled, and actual 
fields, see the "Fields" topic, both in the Microsoft Project User's Reference.

SCHEDULED START
Calculated

Date the resource is scheduled to begin working on this task. The scheduled start 
date takes into consideration the resource calendar.

For more information about using this field, see the "Scheduling Methods" topic, and 
for more information about the relationship between planned, scheduled, and actual 
fields, see the "Fields" topic, both in the Microsoft Project User's Reference.

TASK NAME
Calculated

This field appears only on the Resource Form and is the name of the task to which the
resource is assigned. This information is entered by Microsoft Project and cannot be 
edited.

For more information, see the "Scheduling Methods" topic in the Microsoft Project 
User's Reference.

UNITS
Entered

Number of units of this resource assigned to this task. The default is 1. To indicate 
that multiple units are assigned, type a value greater than 1. For example, if you 
want to assign three carpenters, type 3 in the Units field for the carpenter 
assignment. To use a single resource part-time on a task, type a decimal number in 
the Units field that represents the percentage of the resource's daily time spent on 



the task. For example, if you type .25 in the Units field, you are assigning 25 percent 
of a resource's day. If you type 0 in this field, you can enter a fixed cost for the 
resource assignment.

For more information, see the "Assigning Resources" topic in the Microsoft Project 
User's Reference.

WORK
Calculated or Entered

Amount of work scheduled to be performed by this resource on this task. This 
includes any overtime work specified in the Overtime Work field. However, only 
nonovertime, or standard, work is scheduled. For example, if the Overtime Work field 
contains 3 hours and the Work field contains 11 hours, then 8 hours are scheduled 
and charged at the standard rate, and 3 hours are charged at the overtime rate.

If a task's schedule is resource-driven (if the Fixed check box is cleared), the duration 
of the task is calculated from the work and units of the assigned resources. If you 
override the calculated duration by typing a value in the task's Duration field, 
Microsoft Project recalculates the work for each resource by multiplying the duration 
you entered by the assigned number of units. For example, if you type a duration of 
30h and you have two plumbers assigned (Units = 2) and one apprentice plumber 
assigned, each unit is assigned 30 hours of work (60h total for the two plumbers and 
30h for the apprentice plumber).

If a task's schedule is fixed (the Fixed check box is selected), the work you enter for 
the assigned resources does not affect the task's duration.

For more information, see the "Assigning Resources" and "Scheduling Methods" 
topics in the Microsoft Project User's Reference.


